« Back
in BGP 路由 思科 read.

BGP fast-external-fallover 实验

实验说明:
BGP fast-external-fallover 命令
BGP fast external fallover is enabled by default in Cisco IOS software.
默认启用.
 
The bgp fast-external-fallover command is used to disable or enable fast external fallover for BGP peering sessions with directly connected external peers. The session is immediately reset if link goes down. Only directly connected peering sessions are supported.
bgp fast-external-fallover命令作用于直连外部邻居的BGP邻居会话,关闭或启用快速BGP链路检测.
 
If BGP fast external fallover is disabled, the BGP routing process will wait until the default hold timer expires (3 keepalives) to reset the peering session. BGP fast external fallover can also be configured on a per-interface basis using the ip bgp fast-external-fallover interface configuration command.
如果命令关闭,BGP路由进程将会等到默认的hold时间超时后(3倍keepalives)重新设置邻居会话.此命令也可以基于接口配置ip bgp fast-external-fallover 接口配置命令.
 
 
实验拓扑:  
 

R1-R2

 
 
实验基本配置:
R1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial1/1
 ip address 10.1.12.1 255.255.255.0
 no sh
!
router ospf 1
 router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
 network 10.1.12.0 0.0.0.255 area 0
!
router bgp 1
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 10.1.12.2 remote-as 2
 no auto-summary
!
 
R2:
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial1/0
 ip address 10.1.12.2 255.255.255.0
 !
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.12.0 0.0.0.255 area 0
!
router bgp 2
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 10.1.12.1 remote-as 1
 no auto-summary
!
 
实验现象:
1. R1  BGP fast external fallover 默认开启情况.  R1直连接口shutdown
R1(config)#int s1/1
R1(config-if)#sh
R1(config-if)#end
R1#
00:09:25: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from FULL to DOWN, Neighbor Down: Interface down or detached
00:09:25: BGP: service reset requests
00:09:25: BGP: service reset requests
00:09:25: BGP: service reset requests
00:09:25: BGP: 10.1.12.2 reset due to Interface flap
R1#
00:09:25: %BGP-5-ADJCHANGE: neighbor 10.1.12.2 Down Interface flap
00:09:26: %SYS-5-CONFIG_I: Configured from console by console
R1#
00:09:27: %LINK-5-CHANGED: Interface Serial1/1, changed state to administratively down
00:09:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
R1#
00:09:29: BGP: Import timer expired. Walking from 1 to 1
R1#
 
1s内,R1检测认为 BGP邻居关系 down..
 
 
2. R1  BGP fast external fallover 关闭情况.  R1直连接口shutdown
 no bgp fast-external-fallover
 
R1(config)#int s1/1
R1(config-if)#sh
R1(config-if)#end
R1#
00:04:54: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from FULL to DOWN, Neighbor Down: Interface down or detached
00:04:54: %SYS-5-CONFIG_I: Configured from console by console
R1#
00:04:56: %LINK-5-CHANGED: Interface Serial1/1, changed state to administratively down
00:04:57: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
R1#
00:04:59: BGP: Performing BGP general scanning
00:04:59: BGP(0): scanning IPv4 Unicast routing tables
00:04:59: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
00:04:59: BGP(1): scanning VPNv4 Unicast routing tables
00:04:59: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
00:04:59: BGP(2): scanning IPv4 Multicast routing tables
00:04:59: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan
R1#
00:05:14: BGP: Import timer expired. Walking from 1 to 1
R1#
00:05:29: BGP: Import timer expired. Walking from 1 to 1
R1#
00:05:44: BGP: Import timer expired. Walking from 1 to 1
R1#
00:05:59: BGP: Performing BGP general scanning
00:05:59: BGP(0): scanning IPv4 Unicast routing tables
00:05:59: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
00:05:59: BGP(1): scanning VPNv4 Unicast routing tables
00:05:59: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
00:05:59: BGP(2): scanning IPv4 Multicast routing tables
00:05:59: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan
R1#
00:06:14: BGP: Import timer expired. Walking from 1 to 1
R1#
00:06:29: BGP: Import timer expired. Walking from 1 to 1
R1#
00:06:44: BGP: Import timer expired. Walking from 1 to 1
R1#
00:06:59: BGP: Performing BGP general scanning
00:06:59: BGP(0): scanning IPv4 Unicast routing tables
00:06:59: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
00:06:59: BGP(1): scanning VPNv4 Unicast routing tables
00:06:59: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
00:06:59: BGP(2): scanning IPv4 Multicast routing tables
00:06:59: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan
R1#
00:07:14: BGP: Import timer expired. Walking from 1 to 1
R1#
00:07:29: BGP: Import timer expired. Walking from 1 to 1
R1#
00:07:32: BGP: 10.1.12.2 reset due to BGP Notification sent
00:07:32: %BGP-5-ADJCHANGE: neighbor 10.1.12.2 Down BGP Notification sent
R1#
00:07:32: %BGP-3-NOTIFICATION: sent to neighbor 10.1.12.2 4/0 (hold time expired) 0 bytes
R1#
00:07:34: BGP: service reset requests
00:07:34: BGP: service reset requests
00:07:34: BGP: service reset requests
R1#
 
R1等到默认的hold timer超时(3倍keepalives)时 ,才认为BGP邻居down并重设置对等体会话.